欢迎光临 - 我的站长站,本站所有资源仅供学习与参考,禁止用于商业用途或从事违法行为!

php教程

PHP报错SWOOLEC loader ext not installed,及SWOOLEC loader安装方法

php教程 我的站长站 2024-06-23 共7人阅读

为什么报错?

我们在运行PHP项目时,会报错“SWOOLEC loader ext not installed”,这是因为你运行的PHP项目有用到Swoole Loader扩展加密代码,但是你的PHP环境没有安装Swoole Loader扩展,所以我们只需要安装Swoole Loader扩展即可解决这个报错。

解决方法

1、下载Swoole Loader扩展安装包,下载压缩包,然后找到对应你系统的 Swoole Loader扩展文件解压出来。

注意:nginx使用非线程安装版本,apache或IIS使用线程安装。

下载地址:

镜像官网:https://compiler.swoole.com/encryptor/download/

nginx环境:

php7.2 https://compiler.swoole.com/static/loader3.1.0/swoole_loader72.so

php7.3 https://compiler.swoole.com/static/loader3.1.0/swoole_loader73.so

php7.4 https://compiler.swoole.com/static/loader3.1.0/swoole_loader74.so

php8.0 https://compiler.swoole.com/static/loader3.1.0/swoole_loader80.so

php8.1 https://compiler.swoole.com/static/loader3.1.0/swoole_loader81.so

Apache|IIS环境:

php7.2 https://compiler.swoole.com/static/loader3.1.0/swoole_loader72_zts.so

php7.3 https://compiler.swoole.com/static/loader3.1.0/swoole_loader73_zts.so

php7.4 https://compiler.swoole.com/static/loader3.1.0/swoole_loader74_zts.so

php8.0 https://compiler.swoole.com/static/loader3.1.0/swoole_loader80_zts.so

php8.1 https://compiler.swoole.com/static/loader3.1.0/swoole_loader81_zts.so


CSDN下载镜像:

swoole72-81线程安全linux.zip下载地址:https://files.cnblogs.com/files/blogs/818244/swoole72-81%E7%BA%BF%E7%A8%8B%E5%AE%89%E5%85%A8linux.zip?t=1709867088&download=true

swoole72-81线程安全Windows.zip下载地址:https://files.cnblogs.com/files/blogs/818244/swoole72-81%E7%BA%BF%E7%A8%8B%E5%AE%89%E5%85%A8windows.zip?t=1709867088&download=true

swoole72-81非线程安全windows.zip下载地址:https://files.cnblogs.com/files/blogs/818244/swoole72-81%E9%9D%9E%E7%BA%BF%E7%A8%8B%E5%AE%89%E5%85%A8windows.zip?t=1709867087&download=true

swoole72-81非线程安全版本linux.zip下载地址:https://files.cnblogs.com/files/blogs/818244/swoole7.2-8.1%E9%9D%9E%E7%BA%BF%E7%A8%8B%E5%AE%89%E5%85%A8%E7%89%88%E6%9C%AClinux.zip?t=1709867087&download=true

注意:CSDN有防盗链,首先打开CSDN首页:https://blog.csdn.net/,然后复制上面面的链接在CSDN的首页链接上打开。


蓝奏云下载地址:https://wdzzz.lanzoue.com/b0127nkfe 密码:ahop


2、将刚才解压出来的Swoole Loader扩展文件(swoole_loader版本号.dll或swoole_loader版本号.so),上传到当前PHP的扩展安装目录中:ext

PHP报错SWOOLEC loader ext not installed,及SWOOLEC loader安装方法

3、修改php.ini配置,编辑php配置文件:C:\BtSoft\php\72\php.ini,在此文件底部结尾处加入如下配置,extension=刚才上传的文件名.dll,

注意:需要名称和刚才上传到当前PHP的扩展安装目录中的文件名一致(例如:extension=swoole_loader72.dll)

PHP报错SWOOLEC loader ext not installed,及SWOOLEC loader安装方法

4、重启服务,重启或重载PHP配置

标签 SwooleLoader
相关推荐
  • SwooleLoader
  • PHP报错SWOOLEC loader ext not installed,及SWOOLEC loader安装方法
    PHP报错SWOOLEC loader ext not installed,及SWOOLEC loader安装方法

    为什么报错?我们在运行PHP项目时,会报错“SWOOLEC loader ext not installed”,这是因为你运行的PHP项目有用到Swoole Loader扩展加密代码,但是你的PHP环境没有安装Swoole Loader扩展,所以我们只需要...

    php教程 7 3周前
  • 宝塔面板安装Swoole_loader扩展教程(图文)
    宝塔面板安装Swoole_loader扩展教程(图文)

    1、下载Swoole Loader下载地址:https://www.wdzzz.com/jiaocheng/php/3226.html请下载兼容PHP7.2和非线程安全的Swoole Loader扩展,点击下载适配环境的扩展文件2、安装Swoole Loader将刚才下载的Sw...

    宝塔面板 7 1周前